Post actions required to meet Configuration Manager 2012 SP1 supported (SQL) Configuration #sysctr


When you install a secondary site, you can use an existing instance of SQL Server or allow Setup to install and use an instance of SQL Server Express. Whichever option that you choose, SQL Server must be located on the secondary site server. The version of SQL Server Express that Setup installs depends on the version of Configuration Manager that you use.

image 

http://technet.microsoft.com/library/gg682077.aspx#BKMK_SupConfigSQLDBconfig

When the setup of a secondary site fails for some reason(s) and you re-run the setup and re-use the SQL Server Express instance – which was previously installed on the first attempt – the prerequisite checker indicates the that SQL Server (Express) version is not supported which results the setup will not continue.

clip_image002

Having a closer look using ConfigMgrPrereq.log and ConfigMgrSetup.log the reason why the setup of the secondary site server failed is clear:

SQL Server version;    Error;    Configuration Manager sites require a supported SQL Server version with required hotfixes for site database operations to succeed. Before Setup can continue, you must install a supported version of SQL Server on the specified site database server. For more information, see http://go.microsoft.com/fwlink/p/?LinkID=232936

With Configuration Manager 2012 SP1 an unsupported version of SQL Server Express (11.0.2100.60 – RTM) is installed on secondary site servers. This SQL instance does not contain CU2 or SP1.

The SQL Server version can be determined through various ways including the Configuration Manager Prerequisite Checker or SQL Server Management Studio.

clip_image001

For the record when you are deploying a secondary site server based on Configuration Manager 2012 RTM the SQL Server version installed is SQL Server 2008 R2 Express SP1, which means no post actions are required.

clip_image001

Unsupported doesn’t means it isn’t working – actually it is working fine. I am wondering if you aware of this and have updated your secondary site server(s) to meet SQL Sever 2012 Express at least CU2 or SP1? 

clip_image001[5]

Bottom-line, based on the Supported Configurations for Configuration Manager documentation and the pre-requisites checker – SQL Server 2012 Express with a minimum of CU2 or SQL Server 2012 SP1 must be installed afterwards a Secondary Site Server setup in order to meet a supported Configuration Manager configuration.

A close member of the Configuration Manager Product Team confirmed this behavior and committed some guidance on this topic to be expected on TechNet (aka update product documentation).

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s